Navigation


Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#26 closed defect (wontfix)

OpenWRT's uClibc support is BROKEN

Reported by: Sebastien Decugis Owned by: Administrator
Priority: major Milestone:
Component: framework Version: tip
Keywords: openwrt Cc: dev@freediameter.net
Blocked By: Blocking:

Description

The OpenWRT platform does not provide a correct support for POSIX cancelation handlers (pthread_cleanup_{push,pop}) which leads the framework to misbehave / hang in several places.

Change History (2)

comment:1 Changed 11 years ago by Sebastien Decugis

Resolution: wontfix
Status: newclosed

Since the problem is in uClibc, there is not much to do in freeDiameter at this level...

comment:2 Changed 11 years ago by Sebastien Decugis

Summary: OpenWRT support is BROKENOpenWRT's uClibc support is BROKEN

WORKAROUND: it is possible to compile OpenWRT image with glibc support instead of default uClibc. Check 701 for more details.

Note: See TracTickets for help on using tickets.