comparison contrib/debian/changelog @ 1542:8d7d4e1dfea8

changelog: document changes I've made since v1.4.0
author Luke Mewburn <luke@mewburn.net>
date Fri, 01 May 2020 19:49:27 +1000
parents a52a1dbae99f
children 224cb55be2d7
comparison
equal deleted inserted replaced
1541:3365e95bed57 1542:8d7d4e1dfea8
1 freediameter (UNRELEASED) UNRELEASED; urgency=low
2
3 * freeDiameter:
4 - Add -g to help
5 - Change -d and -q to control syslog level, as per stdout logging.
6 - Syslog to LOG_DAEMON.
7 - Actually syslog to LOG_DEBUG, now that -d/-q are used.
8 - Add -p pidfile
9 - SCTP client: bind to local endpoints configured with ListenOn so
10 that the SCTP INIT only contains those local endpoint addresses,
11 matching what is advertised in the CER.
12 * Base dictionary: Add rules for Experimental-Result.
13 * All extensions: Hide symbols except for fd_ext_init() and fd_ext_fini().
14 * dbg_dict_dump.fdx: add extension to write the dictionary
15 to the given file or to the log.
16 * dbg_dict_dump_json.fdx: add extension to write the dictionary as JSON
17 to the given file or stdout.
18 * dict_dcca_3gpp.fdx: Update to 3GPP Release 15, adding many standards.
19 This adds 96 TYPEs, 145 ENUMVALs, 791 AVPs, 52 RULEs.
20 There are various breaking changes (documented below).
21 * contrib/dictionary_dcca_3gpp.json: Remove non-3GPP AVPs that are
22 actually from base IETF RFCs:
23 - MIP6-Feature-Vector (124). IETF RFC 5447
24 - Service-Selection (493). IETF RFC 5778
25 - Mobile-Node-Identifier (506). IETF RFC 5779
26 - QoS-Capability (578). IETF RFC 5777.
27 * New API: fd_msg_add_result(): set Result-Code or Experimental-Result.
28 * New API: log level FD_LOG_INFO.
29 * fd_conf_dump(): fix formatting of local endpoints.
30 * fd_msg_search_avp(): support searching avp as well as msg.
31 * Fix compiler warnings.
32 * Add ERRORS_ON_WARNINGS cmake boolean to enable fatal compiler warnings.
33 * New tool: grep_fd_dict_dump: cleanup fd_dict_dump() output in logs.
34 * New tool: csv_to_fd: convert .csv with AVP tables to freeDiameter C or JSON.
35 * New tool: org_to_csv: convert .org files into .csv files.
36
37 * dict_dcca_3gpp.fdx changes per update to 3GPP Release 15 as at 2019-12:
38 - AVP changes:
39 - 3GPP-CG-IPv6-Address (14) renamed to 3GPP-CG-Ipv6-Address (14).
40 - 3GPP-GGSN-IPv6-Address (16) renamed to 3GPP-GGSN-Ipv6-Address (16).
41 - 3GPP-IPv6-DNS-Servers (17) renamed to 3GPP-Ipv6-DNS-Servers (17).
42 - 3GPP-SGSN-IPv6-Address (15) renamed to 3GPP-SGSN-Ipv6-Address (15).
43 - 3GPP2-BSID (9010) flag M MUST.
44 - 3GPP2-BSID (9010) type changed from OctetString to UTF8String.
45 - ADC-Revalidation-Time (2801) Time removed in 3GPP TS 29.212 V12.1.0 (2013-06).
46 - ADC-Rule-Base-Name (1095) flag M MUST.
47 - ADC-Rule-Definition (1094) flag M MUST.
48 - ADC-Rule-Install (1092) flag M MUST.
49 - ADC-Rule-Name (1096) flag M MUST.
50 - ADC-Rule-Remove (1093) flag M MUST.
51 - ADC-Rule-Report (1097) flag M MUST.
52 - Application-Service-Type (2102) type changed from UTF8String to Enumerated.
53 - Application–Session–Id (2103) type changed from UTF8String to Unsigned32.
54 - Call-Barring-Infor-List (1488) renamed to Call-Barring-Info (1488).
55 - External-Identifier (28) OctetString replaced by External-Identifier (3111) UTF8String.
56 - LCS-Requestor-Id (1239) renamed to LCS-Requestor-ID (1239).
57 - LCS-Requestor-Id-String (1240) renamed to LCS-Requestor-ID-String (1240).
58 - MBMS-BMSC-SSM-IPv6-Address (919) renamed to MBMS-BMSC-SSM-Ipv6-Address (919).
59 - MBMS-GGSN-IPv6-Address (917) renamed to MBMS-GGSN-Ipv6-Address (917).
60 - MBMSGW-Address (2307) renamed to MBMS-GW-Address (2307).
61 - Measurement-Period-LTE (1656) code changed to Measurement-Period-LTE (1655).
62 - Measurement-Period-UMTS (1655) code changed to Measurement-Period-UMTS (1656).
63 - MME-LocationInformation (1600) renamed to MME-Location-Information(1600).
64 - PDG-Address (895) Address removed in 3GPP TS 32.299 V12.6.0 (2014-09).
65 - PDG-Charging-Id (896) Unsigned32 removed in 3GPP TS 32.299 V12.6.0 (2014-09).
66 - PDN-Connection-ID (1065) flag M MUST NOT.
67 - PoC-User-Role-info-Units (1254) renamed to PoC-User-Role-Info-Units (1254).
68 - PS-to-CS-Session-Continuity (1099) flag M MUST NOT.
69 - SS-Status (1477) type changed from Grouped to OctetString.
70 - Status (2702) renamed to Status-AS-Code (2702).
71 - WAG-Address (890) Address removed in 3GPP TS 32.299 V12.6.0 (2014-09).
72 - WAG-PLMN-Id (891) OctetString removed in 3GPP TS 32.299 V12.6.0 (2014-09).
73 - WLAN-Information (875) Grouped removed in 3GPP TS 32.299 V12.6.0 (2014-09).
74 - WLAN-Radio-Container (892) Grouped removed in 3GPP TS 32.299 V12.6.0 (2014-09).
75 - WLAN-Session-Id (1246) UTF8String removed in 3GPP TS 32.299 V12.6.0 (2014-09).
76 - WLAN-Technology (893) Unsigned32 removed in 3GPP TS 32.299 V12.6.0 (2014-09).
77 - WLAN-UE-Local-IPAddress (894) Address removed in 3GPP TS 32.299 V12.6.0 (2014-09).
78 - AVP renames:
79 - Rename Call-Barring-Infor-List (1488) to Call-Barring-Info (1488).
80 - Rename LCS-Requestor-Id (1239) to LCS-Requestor-ID (1239).
81 - Rename LCS-Requestor-Id-String (1240) to LCS-Requestor-ID-String (1240).
82 - Rename MBMSGW-Address (2307) to MBMS-GW-Address (2307).
83 - Rename MME-LocationInformation (1600) to MME-Location-Information(1600).
84 - Rename PoC-User-Role-info-Units (1254) to PoC-User-Role-Info-Units (1254).
85 - Rename Status (2702) to Status-AS-Code (2702).
86 - AVP name conflicts:
87 - Time-Window (3818) in 3GPP TS 29.345 V12.1.0 (2014-12) predates
88 Time-Window-29.154 (4204) in 3GPP TS 29.154 V13.1.0 (2016-03).
89 - Add Enumerated(3GPP/Experimental-Result-Code). 145 values.
90 - Update standards:
91 - 3GPP TS 29.061 V15.5.0 (2018-12). 15 AVPs.
92 - 3GPP TS 29.173 V15.0.0 (2018-06). 1 AVP.
93 - 3GPP TS 29.212 V15.9.0 (2019-12). 46 AVPs.
94 - 3GPP TS 29.214 V15.7.0 (2019-09). 27 AVPs.
95 - 3GPP TS 29.229 V15.2.0 (2019-09). 8 AVPs.
96 - 3GPP TS 29.272 V15.10.0 (2019-12). 44 AVPs.
97 - 3GPP TS 29.329 V15.2.0 (2019-09). 5 AVPs.
98 - 3GPP TS 32.299 V15.7.0 (2019-06). 154 AVPs.
99 - Add standards:
100 - 3GPP TS 29.109 V15.0.0 (2017-06). 21 AVPs.
101 - 3GPP TS 29.128 V15.6.0 (2019-09). 25 AVPs.
102 - 3GPP TS 29.153 V15.1.0 (2019-09). 2 AVPs.
103 - 3GPP TS 29.154 V15.3.0 (2019-09). 16 AVPs.
104 - 3GPP TS 29.172 V15.2.0 (2019-12). 66 AVPs.
105 - 3GPP TS 29.209 V6.8.0 (2011-09). 2 AVPs.
106 - 3GPP TS 29.215 V15.2.0 (2019-09). 9 AVPs.
107 - 3GPP TS 29.217 V15.1.0 (2019-09). 14 AVPs.
108 - 3GPP TS 29.219 V15.3.0 (2019-09). 7 AVPs.
109 - 3GPP TS 29.234 V11.2.0 (2013-06). 19 AVPs.
110 - 3GPP TS 29.273 V15.4.0 (2019-09). 40 AVPs.
111 - 3GPP TS 29.283 V15.1.0 (2019-09). 16 AVPs.
112 - 3GPP TS 29.336 V15.7.0 (2019-09). 79 AVPs.
113 - 3GPP TS 29.337 V15.0.0 (2018-06). 4 AVPs.
114 - 3GPP TS 29.338 V15.1.0 (2018-12). 34 AVPs.
115 - 3GPP TS 29.343 V15.1.0 (2019-09). 13 AVPs.
116 - 3GPP TS 29.344 V15.1.0 (2019-09). 7 AVPs.
117 - 3GPP TS 29.345 V15.1.0 (2019-09). 68 AVPs.
118 - 3GPP TS 29.368 V15.1.0 (2019-09). 12 AVPs.
119 - 3GPP TS 29.388 V15.1.0 (2019-09). 3 AVPs.
120 - 3GPP TS 29.389 V15.1.0 (2019-09). 3 AVPs.
121 - 3GPP TS 29.468 V15.8.0 (2019-12). 33 AVPs.
122 - 3GPP TS 29.561 V16.3.0 (2020-03). 9 AVPs.
123
1 freediameter (1.4.0) RELEASED; urgency=low 124 freediameter (1.4.0) RELEASED; urgency=low
2 125
3 * New API: fd_fifo_set_max to change the capacity of a queue. 126 * New API: fd_fifo_set_max to change the capacity of a queue.
4 * New configuration stanza for Relays: ProcessingPeersPattern and ProcessingPeersMinimum 127 * New configuration stanza for Relays: ProcessingPeersPattern and ProcessingPeersMinimum
5 * New configuration stanza for scalability: RoutingInThreads and RoutingOutThreads 128 * New configuration stanza for scalability: RoutingInThreads and RoutingOutThreads
"Welcome to our mercurial repository"