comparison INSTALL.FreeBSD @ 234:f91fe0b85928

Updated INSTALL files
author Sebastien Decugis <sdecugis@nict.go.jp>
date Thu, 04 Mar 2010 17:32:00 +0900
parents
children 62eaf631eb61
comparison
equal deleted inserted replaced
233:87ca7b66a90c 234:f91fe0b85928
1 See INSTALL file for general instructions on building freeDiameter.
2
3 ------------------
4 QUICK INSTRUCTIONS
5 ------------------
6
7 On FreeBSD-8.0 the following packages were required (should be same on FreeBSD-7.x):
8 cmake flex bison gnutls
9
10 Then the cmake command had to look like:
11 cmake -DFLEX_EXECUTABLE:FILEPATH=/usr/local/bin/flex ...
12
13
14 ---------------------
15 COMPLETE INSTRUCTIONS
16 ---------------------
17
18 1) If you don't have freeBSD yet:
19 Install minimal system + ports using initial installer /usr/sbin/sysinstall
20
21
22 2) Install cmake
23
24 a) from sources:
25 # cd /usr/ports/devel/cmake
26 # make install
27
28 b) from package (don't forget to set your PACKAGEROOT appropriately: set PACKAGEROOT=ftp://ftp.jp.freebsd.org):
29 # pkg_add -v -r cmake
30
31
32 3) Install mercurial (optional)
33 (replace "cmake" by "mercurial" in the previous command)
34
35 4) Install flex and bison.
36
37 5) Retrieve freeDiameter source code:
38 # cd ~
39 # /usr/local/bin/hg clone http://aaa.koganei.wide.ad.jp/hg/freeDiameter/
40
41 6) Make a build directory
42 # mkdir fD-build
43 # cd fD-build
44
45 7) Run cmake for freeDiameter (add other flags as you see fit, see INSTALL for more details)
46 # cmake -DFLEX_EXECUTABLE:FILEPATH=/usr/local/bin/flex ../freeDiameter
47
48 8) make, run, enjoy :)
"Welcome to our mercurial repository"