diff include/freeDiameter/CMakeLists.txt @ 933:04f590da5821

Add cmake option DISABLE_PEER_EXPIRY to disable dynamic peer expiration mechanism
author Sebastien Decugis <sdecugis@freediameter.net>
date Wed, 06 Mar 2013 16:39:07 +0100
parents 254d81d21d0b
children 6072619402a3
line wrap: on
line diff
--- a/include/freeDiameter/CMakeLists.txt	Sun Mar 03 09:16:42 2013 +0100
+++ b/include/freeDiameter/CMakeLists.txt	Wed Mar 06 16:39:07 2013 +0100
@@ -24,7 +24,12 @@
 	OPTION (DIAMID_IDNA_REJECT "Reject internationalized Diameter Identities, do not attempt to convert it (stringprep) ?" OFF)
 ENDIF (NOT DIAMID_IDNA_IGNORE)
 
-MARK_AS_ADVANCED(DISABLE_SCTP DEBUG_SCTP SCTP_USE_MAPPED_ADDRESSES ERRORS_ON_TODO DIAMID_IDNA_IGNORE DIAMID_IDNA_REJECT)
+# Disable expiration of connections with dynamically connected peers as per RFC 3539 ? (default is enabled)
+# Note: if someone needs, we could also make the delay configurable here...
+OPTION(DISABLE_PEER_EXPIRY "Disable RFC3539 Peers Connections Expiration after inactivity?" OFF)
+
+
+MARK_AS_ADVANCED(DISABLE_SCTP DEBUG_SCTP SCTP_USE_MAPPED_ADDRESSES ERRORS_ON_TODO DIAMID_IDNA_IGNORE DIAMID_IDNA_REJECT DISABLE_PEER_EXPIRY)
 
 ########################
 ### System checks part
"Welcome to our mercurial repository"