diff libfdproto/CMakeLists.txt @ 1159:05f74dc19c49

Include source rev number in version information when available
author Sebastien Decugis <sdecugis@freediameter.net>
date Fri, 31 May 2013 11:20:27 +0800
parents 765134772e47
children 38e4a7c318ac
line wrap: on
line diff
--- a/libfdproto/CMakeLists.txt	Fri May 31 11:19:35 2013 +0800
+++ b/libfdproto/CMakeLists.txt	Fri May 31 11:20:27 2013 +0800
@@ -1,6 +1,7 @@
 # Name of the subproject
 Project("libfdproto" C)
 
+
 # List of source files for the library
 SET(LFDPROTO_SRC
 	fdproto-internal.h
@@ -17,8 +18,10 @@
 	rt_data.c
 	sessions.c
 	utils.c
+	version.c
 	)
 
+
 # Save the list of files for testcases in the core's directory
 SET(LFDPROTO_SRC ${LFDPROTO_SRC} PARENT_SCOPE)
 
@@ -28,6 +31,8 @@
 # Build as a shared library
 ADD_LIBRARY(libfdproto SHARED ${LFDPROTO_SRC})
 
+ADD_DEPENDENCIES(libfdproto version_information)
+
 # Avoid the liblib name, and set the version
 SET_TARGET_PROPERTIES(libfdproto PROPERTIES 
 	OUTPUT_NAME "fdproto"
"Welcome to our mercurial repository"