diff libfreediameter/CMakeLists.txt @ 0:13530e1f02e3

Initial files imported
author Sebastien Decugis <sdecugis@nict.go.jp>
date Fri, 28 Aug 2009 19:14:42 +0900
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/libfreediameter/CMakeLists.txt	Fri Aug 28 19:14:42 2009 +0900
@@ -0,0 +1,25 @@
+# Name of the subproject
+Project("libfreediameter" C)
+
+SET(PROJECT_COPYRIGHT "Copyright (c) 2008-2009, WIDE Project (www.wide.ad.jp) and NICT (www.nict.go.jp)")
+
+# List of source files for the library
+SET(LFD_SRC
+	libfd.h
+	init.c
+	log.c
+	lists.c
+	dictionary.c
+	messages.c
+	mqueues.c
+	)
+
+# Build as a shared library
+ADD_LIBRARY(libfreediameter SHARED ${LFD_SRC})
+
+# Avoid the liblib name
+SET_TARGET_PROPERTIES(libfreediameter PROPERTIES OUTPUT_NAME "freediameter")
+
+# The library itself needs other libraries 
+TARGET_LINK_LIBRARIES(libfreediameter ${FD_LIBS})
+
"Welcome to our mercurial repository"