diff freeDiameter/CMakeLists.txt @ 8:3e143f047f78

Backup for the week-end
author Sebastien Decugis <sdecugis@nict.go.jp>
date Fri, 18 Sep 2009 18:54:07 +0900
parents d8ce06172629
children c5c99c73c2bf
line wrap: on
line diff
--- a/freeDiameter/CMakeLists.txt	Fri Sep 04 18:05:25 2009 +0900
+++ b/freeDiameter/CMakeLists.txt	Fri Sep 18 18:54:07 2009 +0900
@@ -1,17 +1,28 @@
 # The subproject name
 Project("freeDiameterd" C)
 
-SET(PROJECT_VERSION 0.1)
-SET(PROJECT_COPYRIGHT "Copyright (c) 2008-2009, WIDE Project (www.wide.ad.jp) and NICT (www.nict.go.jp)")
+# Configuration parser
+BISON_FILE(fdd.y)
+FLEX_FILE(fdd.l)
+SET_SOURCE_FILES_PROPERTIES(lex.fdd.c fdd.tab.c PROPERTIES COMPILE_FLAGS "-I ${CMAKE_CURRENT_SOURCE_DIR}")
 
 # List of source files
 SET(FD_COMMON_SRC
 	fD.h
+	config.c
+	extensions.c
 	dict_base_proto.c
 	)
 
+SET(FD_COMMON_GEN_SRC
+		lex.fdd.c
+		fdd.tab.c
+		fdd.tab.h
+	)
+
+
 # Building the executable
-ADD_EXECUTABLE(freeDiameterd ${FD_COMMON_SRC} main.c)
+ADD_EXECUTABLE(freeDiameterd ${FD_COMMON_SRC} ${FD_COMMON_GEN_SRC} main.c)
 
 # The link command
 LINK_DIRECTORIES(${CURRENT_BINARY_DIR}/../libfreeDiameter)
@@ -19,6 +30,7 @@
 
 # Save the list of files, if needed
 SET(FD_COMMON_SRC ${FD_COMMON_SRC} PARENT_SCOPE)
+SET(FD_COMMON_GEN_SRC ${FD_COMMON_GEN_SRC} PARENT_SCOPE)
 
 # The unary tests directory
 OPTION(SKIP_TESTS "Skip compilation of the tests?" OFF)
"Welcome to our mercurial repository"