diff include/freeDiameter/CMakeLists.txt @ 378:41e3c2a3721c

Replaced old mechanism to discover local addresses by a call to getifaddrs, lot cleaner! Should close #4
author Sebastien Decugis <sdecugis@nict.go.jp>
date Mon, 05 Jul 2010 16:21:22 +0900
parents aa8f41bca657
children 121397bd1afc
line wrap: on
line diff
--- a/include/freeDiameter/CMakeLists.txt	Mon Jul 05 14:36:50 2010 +0900
+++ b/include/freeDiameter/CMakeLists.txt	Mon Jul 05 16:21:22 2010 +0900
@@ -42,6 +42,11 @@
 # malloc.h ?
 CHECK_INCLUDE_FILES (malloc.h HAVE_MALLOC_H)
 
+# getifaddrs ?
+CHECK_FUNCTION_EXISTS (getifaddrs HAVE_GETIFADDRS)
+IF (NOT HAVE_GETIFADDRS)
+   MESSAGE(SEND_ERROR "The getifaddrs function is currently required by freeDiameter.")
+ENDIF (NOT HAVE_GETIFADDRS)
 
 # pthreads
 INCLUDE(FindThreads)
"Welcome to our mercurial repository"