diff libfdcore/CMakeLists.txt @ 668:4ef3b7cdf734

Some more cleanups in linking
author Sebastien Decugis <sdecugis@nict.go.jp>
date Mon, 17 Jan 2011 14:08:08 +0900
parents bee66d8ca38a
children 018a573b05f0
line wrap: on
line diff
--- a/libfdcore/CMakeLists.txt	Mon Jan 17 13:03:14 2011 +0900
+++ b/libfdcore/CMakeLists.txt	Mon Jan 17 14:08:08 2011 +0900
@@ -58,7 +58,8 @@
 SET_TARGET_PROPERTIES(libfdcore PROPERTIES 
 	OUTPUT_NAME "fdcore"
 	SOVERSION ${FD_PROJECT_VERSION_API}
-	VERSION ${FD_PROJECT_VERSION_MAJOR}.${FD_PROJECT_VERSION_MINOR}.${FD_PROJECT_VERSION_REV})
+	VERSION ${FD_PROJECT_VERSION_MAJOR}.${FD_PROJECT_VERSION_MINOR}.${FD_PROJECT_VERSION_REV}
+	LINK_INTERFACE_LIBRARIES "${LFDCORE_LINK_INTERFACES}")
 
 # The library itself needs other libraries 
 LINK_DIRECTORIES(${CURRENT_BINARY_DIR}/../libfdproto)
"Welcome to our mercurial repository"