diff libfdproto/CMakeLists.txt @ 668:4ef3b7cdf734

Some more cleanups in linking
author Sebastien Decugis <sdecugis@nict.go.jp>
date Mon, 17 Jan 2011 14:08:08 +0900
parents f198d16fa7f4
children 933d098fc75d
line wrap: on
line diff
--- a/libfdproto/CMakeLists.txt	Mon Jan 17 13:03:14 2011 +0900
+++ b/libfdproto/CMakeLists.txt	Mon Jan 17 14:08:08 2011 +0900
@@ -25,7 +25,8 @@
 SET_TARGET_PROPERTIES(libfdproto PROPERTIES 
 	OUTPUT_NAME "fdproto"
 	SOVERSION ${FD_PROJECT_VERSION_API}
-	VERSION ${FD_PROJECT_VERSION_MAJOR}.${FD_PROJECT_VERSION_MINOR}.${FD_PROJECT_VERSION_REV})
+	VERSION ${FD_PROJECT_VERSION_MAJOR}.${FD_PROJECT_VERSION_MINOR}.${FD_PROJECT_VERSION_REV}
+	LINK_INTERFACE_LIBRARIES "${LFDPROTO_LINK_INTERFACES}")
 
 # The library itself needs other libraries 
 TARGET_LINK_LIBRARIES(libfdproto ${LFDPROTO_LIBS})
"Welcome to our mercurial repository"