diff CMakeLists.txt @ 845:5c4cf8d15ef0 1.1.5-rc1

Well this time, I hope, should be the last fix to enable compilation on Darwin systems...
author Sebastien Decugis <sdecugis@freediameter.net>
date Tue, 16 Oct 2012 21:10:14 +0200
parents 84bdbd87cbd5
children cea8e81967eb
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Oct 16 20:06:58 2012 +0200
+++ b/CMakeLists.txt	Tue Oct 16 21:10:14 2012 +0200
@@ -74,6 +74,11 @@
 # Add this to workaround an apparent bug in FreeBSD cmake (already defined in Linux)
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "-rdynamic")
 
+# For Darwin systems
+IF(APPLE)
+   SET(CMAKE_SHARED_MODULE_CREATE_C_FLAGS "${CMAKE_SHARED_MODULE_CREATE_C_FLAGS} -flat_namespace -undefined suppress")
+ENDIF(APPLE) 
+
 # Location for the include files
 INCLUDE_DIRECTORIES(include)
 INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR}/include)
"Welcome to our mercurial repository"