diff extensions/CMakeLists.txt @ 380:6641d6f80cb6

Added test app for Diameter-SIP(client side)
author Alexandre Westfahl <awestfahl@freediameter.net>
date Mon, 05 Jul 2010 17:08:51 +0900
parents 5b199400a290
children 8e260030f32c
line wrap: on
line diff
--- a/extensions/CMakeLists.txt	Mon Jul 05 17:04:46 2010 +0900
+++ b/extensions/CMakeLists.txt	Mon Jul 05 17:08:51 2010 +0900
@@ -102,6 +102,11 @@
  	   SUBDIRS(test_app)
  	ENDIF (BUILD_TEST_APP)
 
+OPTION(BUILD_TEST_APP "Build test_sip.fdx? (Testing application to simulate Diameter-SIP client (RFC4740), for testing purpose only)" OFF)
+ 	IF (BUILD_TEST_SIP)
+ 	   SUBDIRS(test_sip)
+ 	ENDIF (BUILD_TEST_SIP)
+ 	
 # The following extension have very little use except for specific tests, so we disable them except in Debug configurations.
 IF (CMAKE_BUILD_TYPE MATCHES "Debug")
 	OPTION(BUILD_SAMPLE "Build sample.fdx? (Simple extension to demonstrate extension mechanism, for developpers only)" OFF)
"Welcome to our mercurial repository"