diff libfdproto/CMakeLists.txt @ 1561:699c3fb0c57b

Switch from libidn to libidn2. libidn2 is the backwards compatible successor to libidn, and at least Red Hat 8 does not provide a dev package for libidn1.
author Thomas Klausner <wiz@gatalith.at>
date Wed, 16 Jun 2021 18:44:45 +0200
parents 9084c6f94a0a
children
line wrap: on
line diff
--- a/libfdproto/CMakeLists.txt	Wed Jun 16 18:05:27 2021 +0200
+++ b/libfdproto/CMakeLists.txt	Wed Jun 16 18:44:45 2021 +0200
@@ -27,12 +27,12 @@
 # Save the list of files for testcases in the core's directory
 SET(LFDPROTO_SRC ${LFDPROTO_SRC} PARENT_SCOPE)
 
-# Include path
-INCLUDE_DIRECTORIES(${LFDPROTO_INCLUDES})
-
 # Build as a shared library
 ADD_LIBRARY(libfdproto SHARED ${LFDPROTO_SRC})
 
+# Include path
+TARGET_INCLUDE_DIRECTORIES(libfdproto PRIVATE /a/b/c ${LFDPROTO_INCLUDES})
+
 ADD_DEPENDENCIES(libfdproto version_information)
 
 # Avoid the liblib name, and set the version
"Welcome to our mercurial repository"