diff libfreeDiameter/CMakeLists.txt @ 300:71e508379671

Initial test for 'make install' command
author Sebastien Decugis <sdecugis@nict.go.jp>
date Thu, 13 May 2010 17:10:51 +0900
parents 8773740401a5
children ad3c46016584
line wrap: on
line diff
--- a/libfreeDiameter/CMakeLists.txt	Thu May 13 16:57:47 2010 +0900
+++ b/libfreeDiameter/CMakeLists.txt	Thu May 13 17:10:51 2010 +0900
@@ -25,6 +25,11 @@
 # The library itself needs other libraries 
 TARGET_LINK_LIBRARIES(libfreeDiameter ${FD_LIBS})
 
+# The library is to be installed as part of the freeDiameter-common component.
+INSTALL(TARGETS libfreeDiameter
+	LIBRARY DESTINATION lib
+	COMPONENT freeDiameter-common)
+
 # Save the list of files for testcases in the daemon's directory
 SET(LFD_SRC ${LFD_SRC} PARENT_SCOPE)
 
"Welcome to our mercurial repository"