diff CMakeLists.txt @ 1119:79dd22145f52

Fix a number of compilation warnings
author Sebastien Decugis <sdecugis@freediameter.net>
date Tue, 14 May 2013 11:04:20 +0800
parents a7d8273b7506
children c748e2439a3a
line wrap: on
line diff
--- a/CMakeLists.txt	Tue May 14 09:56:36 2013 +0800
+++ b/CMakeLists.txt	Tue May 14 11:04:20 2013 +0800
@@ -51,6 +51,9 @@
 # Add a "DebianPackage" build type used when creating the Debian packages
 SET(CMAKE_C_FLAGS_DEBIANPACKAGE "${CMAKE_C_FLAGS_RELWITHDEBINFO}")
 
+# Set the "Debug" flags
+SET(CMAKE_C_FLAGS_DEBUG "-Wall -g -O0")
+
 # Add a "DebugValgrind" build type used for checking execution with Valgrind tool
 SET(CMAKE_C_FLAGS_DEBUGVALGRIND "-Wall -g -O0")
 
"Welcome to our mercurial repository"