diff freeDiameter/CMakeLists.txt @ 592:7ed07736c661

Fix issue about gcrypt for Fedora, and added INSTALL file for this distribution
author Sebastien Decugis <sdecugis@nict.go.jp>
date Mon, 01 Nov 2010 18:46:39 +0900
parents 1cb9352359f4
children
line wrap: on
line diff
--- a/freeDiameter/CMakeLists.txt	Mon Nov 01 18:24:19 2010 +0900
+++ b/freeDiameter/CMakeLists.txt	Mon Nov 01 18:46:39 2010 +0900
@@ -59,6 +59,16 @@
 MARK_AS_ADVANCED(GCRYPT_INCLUDE_DIR)
 INCLUDE_DIRECTORIES(${GCRYPT_INCLUDE_DIR})
 
+# Also we need libgcrypt to... display its version :(
+find_library(GCRYPT_LIBRARY 
+  NAMES gcrypt
+)
+If ( NOT GCRYPT_LIBRARY )
+	MESSAGE(SEND_ERROR "Unable to find libgcrypt, please install libgcrypt or equivalent")
+Endif ( NOT GCRYPT_LIBRARY )
+SET(FD_LIBS ${FD_LIBS} ${GCRYPT_LIBRARY})
+
+
 
 # Build the executable
 ADD_EXECUTABLE(freeDiameterd ${FD_COMMON_SRC} ${FD_COMMON_GEN_SRC} main.c)
"Welcome to our mercurial repository"