diff include/freeDiameter/CMakeLists.txt @ 1295:a22d9e907d48

Make the stripped output the default. Define DEBUG_WITH_META to get longer format.
author Sebastien Decugis <sdecugis@freediameter.net>
date Fri, 19 Jun 2015 00:00:10 +0800
parents 0aeb09ef20f1
children cbe1da7a32f1
line wrap: on
line diff
--- a/include/freeDiameter/CMakeLists.txt	Thu Jun 18 23:01:08 2015 +0800
+++ b/include/freeDiameter/CMakeLists.txt	Fri Jun 19 00:00:10 2015 +0800
@@ -15,8 +15,8 @@
 # Find TODO items in the code easily ?
 OPTION(ERRORS_ON_TODO "(development) Generate compilation errors on TODO items ?" OFF)
 
-# In DEBUG mode, each log contains pid, calling function and file for easy debug. Set to ON to strip this information.
-OPTION(DEBUG_WITHOUT_META "Strip calling location in logs?" OFF)
+# In DEBUG mode, each log can contain pid, calling function and file for easy debug. Set to ON to display this information.
+OPTION(DEBUG_WITH_META "Show calling location in logs?" OFF)
 	
 # Create the absolute path for searching extensions
 SET(DEFAULT_EXTENSIONS_PATH ${CMAKE_INSTALL_PREFIX}/${INSTALL_EXTENSIONS_SUFFIX})
@@ -36,7 +36,7 @@
 # compliancy of their implementation with the Diameter RFC...
 OPTION(WORKAROUND_ACCEPT_INVALID_VSAI "Do not reject a CER/CEA with a Vendor-Specific-Application-Id AVP containing both Auth- and Acct- application AVPs?" OFF)
 
-MARK_AS_ADVANCED(DISABLE_SCTP DEBUG_SCTP SCTP_USE_MAPPED_ADDRESSES ERRORS_ON_TODO DEBUG_WITHOUT_META DIAMID_IDNA_IGNORE DIAMID_IDNA_REJECT DISABLE_PEER_EXPIRY WORKAROUND_ACCEPT_INVALID_VSAI)
+MARK_AS_ADVANCED(DISABLE_SCTP DEBUG_SCTP SCTP_USE_MAPPED_ADDRESSES ERRORS_ON_TODO DEBUG_WITH_META DIAMID_IDNA_IGNORE DIAMID_IDNA_REJECT DISABLE_PEER_EXPIRY WORKAROUND_ACCEPT_INVALID_VSAI)
 
 ########################
 ### System checks part
"Welcome to our mercurial repository"