diff freeDiameter/CMakeLists.txt @ 304:ad3c46016584

Added install directives for cmake; also allow default directory to seek for extensions and configuration files
author Sebastien Decugis <sdecugis@nict.go.jp>
date Fri, 14 May 2010 17:26:53 +0900
parents 71e508379671
children 61f78fdbacc2
line wrap: on
line diff
--- a/freeDiameter/CMakeLists.txt	Fri May 14 10:42:49 2010 +0900
+++ b/freeDiameter/CMakeLists.txt	Fri May 14 17:26:53 2010 +0900
@@ -51,6 +51,7 @@
 If ( NOT GCRYPT_INCLUDE_DIR )
 	MESSAGE(SEND_ERROR "Unable to find gcrypt.h, please install libgcrypt-dev or equivalent")
 Endif ( NOT GCRYPT_INCLUDE_DIR )
+MARK_AS_ADVANCED(GCRYPT_INCLUDE_DIR)
 INCLUDE_DIRECTORIES(${GCRYPT_INCLUDE_DIR})
 
 # Building the executable
@@ -63,17 +64,23 @@
 LINK_DIRECTORIES(${CURRENT_BINARY_DIR}/../libfreeDiameter)
 TARGET_LINK_LIBRARIES(freeDiameterd libfreeDiameter ${FD_LIBS})
 
-# The daemon is to be installed as part of the freeDiameter-daemon component.
-INSTALL(TARGETS freeDiameterd
-	RUNTIME DESTINATION bin
-	COMPONENT freeDiameter-daemon)
-
 # Save the list of files, if needed
 SET(FD_COMMON_SRC ${FD_COMMON_SRC} PARENT_SCOPE)
 SET(FD_COMMON_GEN_SRC ${FD_COMMON_GEN_SRC} PARENT_SCOPE)
 
 # The unary tests directory
-OPTION(SKIP_TESTS "Skip compilation of the tests?" OFF)
+OPTION(SKIP_TESTS "Skip compilation of the tests?" ON)
 IF ( NOT SKIP_TESTS )
 	SUBDIRS(tests)
 ENDIF ( NOT SKIP_TESTS )
+IF (NOT CMAKE_BUILD_TYPE MATCHES "Debug")
+  MARK_AS_ADVANCED(SKIP_TESTS)
+ENDIF (NOT CMAKE_BUILD_TYPE MATCHES "Debug")
+
+
+####
+## INSTALL section ##
+
+INSTALL(TARGETS freeDiameterd
+	RUNTIME DESTINATION bin
+	COMPONENT freeDiameter-daemon)
"Welcome to our mercurial repository"