diff extensions/dbg_dict_dump/CMakeLists.txt @ 1436:ad50ef2eddea

dbg_dict_dump: new extension to dump dictionary when loaded Add extension dbg_dict_dump to log the dictionary when loaded. Remove debug code in extension dict_dcca_3gpp to log the vendor dictionary if the config file is the word "dumpdict" that I added on 2020-02-19.
author Luke Mewburn <luke@mewburn.net>
date Tue, 25 Feb 2020 09:45:15 +1100
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/extensions/dbg_dict_dump/CMakeLists.txt	Tue Feb 25 09:45:15 2020 +1100
@@ -0,0 +1,12 @@
+# Dictionary dump extension
+PROJECT("Dictionary dump extension" C)
+FD_ADD_EXTENSION(dbg_dict_dump dbg_dict_dump.c)
+
+
+####
+## INSTALL section ##
+
+INSTALL(TARGETS dbg_dict_dump
+	LIBRARY DESTINATION ${INSTALL_EXTENSIONS_SUFFIX}
+	COMPONENT freeDiameter-debug-tools)
+
"Welcome to our mercurial repository"