diff extensions/CMakeLists.txt @ 1341:b0401251d8c0

rt_rewrite: new extension This extension allows rewriting messages: putting data from one AVP into another, or removing AVPs altogether. Written for Effortel Technologies SA and published with their consent.
author Thomas Klausner <tk@giga.or.at>
date Tue, 09 Apr 2019 16:01:29 +0200
parents daf61e573fee
children 2adac053aac4
line wrap: on
line diff
--- a/extensions/CMakeLists.txt	Tue Apr 09 15:57:12 2019 +0200
+++ b/extensions/CMakeLists.txt	Tue Apr 09 16:01:29 2019 +0200
@@ -76,6 +76,7 @@
 FD_EXTENSION_SUBDIR(rt_load_balance "Balance load over multiple equal hosts, based on outstanding requests"	ON)
 FD_EXTENSION_SUBDIR(rt_randomize    "Randomly choose one of the highest scored hosts and increase its score by one"	ON)
 FD_EXTENSION_SUBDIR(rt_redirect     "Handling of Diameter Redirect messages" 			ON)
+FD_EXTENSION_SUBDIR(rt_rewrite      "Convert/remove AVP data in messages" 			ON)
 
 
 ####
"Welcome to our mercurial repository"