diff extensions/CMakeLists.txt @ 1126:d6e18ebca0c5

New extension dbg_msg_dumps for debug / learning.
author Sebastien Decugis <sdecugis@freediameter.net>
date Wed, 15 May 2013 10:05:22 +0800
parents d8591b1c56cd
children 2a7b32176d2e
line wrap: on
line diff
--- a/extensions/CMakeLists.txt	Wed May 15 10:04:58 2013 +0800
+++ b/extensions/CMakeLists.txt	Wed May 15 10:05:22 2013 +0800
@@ -84,9 +84,10 @@
 ####
 # Debug & test extensions
 
-FD_EXTENSION_SUBDIR(dbg_monitor "Outputs periodical status information"              OFF)
-FD_EXTENSION_SUBDIR(dbg_msg_timings "Show some timing information for messages"      OFF)
-FD_EXTENSION_SUBDIR(dbg_rt      "Routing extension for debugging the routing module" OFF)
+FD_EXTENSION_SUBDIR(dbg_monitor "Outputs periodical status information"              ON)
+FD_EXTENSION_SUBDIR(dbg_msg_timings "Show some timing information for messages"      ON)
+FD_EXTENSION_SUBDIR(dbg_msg_dumps "Show human-readable content of the received & sent messages"      ON)
+FD_EXTENSION_SUBDIR(dbg_rt      "Routing extension for debugging the routing module" ON)
 FD_EXTENSION_SUBDIR(test_app    "Testing application to send dummy message to another peer, like a Diameter 'ping'" OFF)
 FD_EXTENSION_SUBDIR(test_sip    "Testing application to simulate Diameter-SIP client (RFC4740)" OFF)
 FD_EXTENSION_SUBDIR(dbg_interactive "Python-interpreter based module"                OFF)
"Welcome to our mercurial repository"