diff extensions/rt_load_balance/CMakeLists.txt @ 1042:dcc0eff204cf

Add extension that balances load over multiple peers based on outstanding requests.
author Thomas Klausner <tk@giga.or.at>
date Thu, 18 Apr 2013 15:50:10 +0200
parents
children 9860ff6e9497
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/extensions/rt_load_balance/CMakeLists.txt	Thu Apr 18 15:50:10 2013 +0200
@@ -0,0 +1,20 @@
+# The rt_load_balance extension
+PROJECT("Routing extension splits requests evenly over multiple hosts, using current load as routing indicator" C)
+
+# List of source files
+SET(RT_IGNORE_DH_SRC
+	rt_load_balance.c
+)
+
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
+
+# Compile these files as a freeDiameter extension
+FD_ADD_EXTENSION(rt_load_balance ${RT_IGNORE_DH_SRC})
+
+####
+## INSTALL section ##
+
+# We install with the daemon component because it is a base feature.
+INSTALL(TARGETS rt_load_balance
+	LIBRARY DESTINATION ${INSTALL_EXTENSIONS_SUFFIX}
+	COMPONENT freeDiameter-daemon)
"Welcome to our mercurial repository"