diff include/freeDiameter/CMakeLists.txt @ 1406:deaa89f4a994

add ERRORS_ON_WARNINGS to enable fatal compiler warnings
author Luke Mewburn <luke@mewburn.net>
date Tue, 18 Feb 2020 16:48:26 +1100
parents cbe1da7a32f1
children 699c3fb0c57b
line wrap: on
line diff
--- a/include/freeDiameter/CMakeLists.txt	Tue Feb 18 16:23:53 2020 +1100
+++ b/include/freeDiameter/CMakeLists.txt	Tue Feb 18 16:48:26 2020 +1100
@@ -15,6 +15,9 @@
 # Find TODO items in the code easily ?
 OPTION(ERRORS_ON_TODO "(development) Generate compilation errors on TODO items ?" OFF)
 
+# Compiler warnings are fatal?
+OPTION(ERRORS_ON_WARNINGS "(development) Compiler warnings cause compilation errors ?" OFF)
+
 # In DEBUG mode, each log can contain pid, calling function and file for easy debug. Set to ON to display this information.
 OPTION(DEBUG_WITH_META "Show calling location in logs?" OFF)
 
"Welcome to our mercurial repository"