diff extensions/app_diameap/CMakeLists.txt @ 823:f145c687c5f3

Add explicit requirement on libgcrypt for app_diameap.fdx, this lib no longer comes implicitely with gnutls in the core
author Sebastien Decugis <sdecugis@freediameter.net>
date Wed, 12 Sep 2012 20:43:51 +0200
parents e7814e24e57b
children 365f1ed01cd1
line wrap: on
line diff
--- a/extensions/app_diameap/CMakeLists.txt	Tue Sep 11 20:51:40 2012 +0200
+++ b/extensions/app_diameap/CMakeLists.txt	Wed Sep 12 20:43:51 2012 +0200
@@ -3,6 +3,7 @@
 
 # Find MySQL 
 FIND_PACKAGE(MySQL REQUIRED)
+FIND_PACKAGE(Gcrypt REQUIRED)
 INCLUDE_DIRECTORIES(${MySQL_INCLUDE_DIR})
 
 # Parse plugins
@@ -45,7 +46,7 @@
 
 FD_ADD_EXTENSION(app_diameap ${diameapsrc})
 
-TARGET_LINK_LIBRARIES(app_diameap ${MySQL_LIBRARY})
+TARGET_LINK_LIBRARIES(app_diameap ${GCRYPT_LIBRARY} ${MySQL_LIBRARY})
 
 ####
 ## INSTALL section ##
"Welcome to our mercurial repository"