diff libfdproto/CMakeLists.txt @ 658:f198d16fa7f4

Initial commit for 1.1.0: * Restructuring: * libfreeDiameter: - renamed folder & binary into libfdproto - renamed libfD.h into fdproto-internal.h - removed signals management (replaced by triggers in libfdcore) * freeDiameter split into: - libfdcore (most contents) - renamed fD.h into fdcore-internal.h - added core.c for framework init/shutdown. - new triggers mechanism in events.c. - freeDiameterd (main, command line parsing, signals management) * tests: - now in top-level directory tests. * other changes: - fd_dict_new now returns 0 on duplicate identical entries. - fixes in dict_legacy_xml - fixes in some dictionaries - moved FD_DEFAULT_CONF_FILENAME definition to freeDiameter-host.h
author Sebastien Decugis <sdecugis@nict.go.jp>
date Fri, 14 Jan 2011 15:15:23 +0900
parents libfreeDiameter/CMakeLists.txt@53f912ce0f4e
children 4ef3b7cdf734
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/libfdproto/CMakeLists.txt	Fri Jan 14 15:15:23 2011 +0900
@@ -0,0 +1,40 @@
+# Name of the subproject
+Project("libfdproto" C)
+
+# List of source files for the library
+SET(LFDPROTO_SRC
+	fdproto-internal.h
+	dictionary.c
+	dispatch.c
+	fifo.c
+	init.c
+	lists.c
+	log.c
+	messages.c
+	rt_data.c
+	sessions.c
+	)
+
+# Save the list of files for testcases in the core's directory
+SET(LFDPROTO_SRC ${LFDPROTO_SRC} PARENT_SCOPE)
+
+# Build as a shared library
+ADD_LIBRARY(libfdproto SHARED ${LFDPROTO_SRC})
+
+# Avoid the liblib name, and set the version
+SET_TARGET_PROPERTIES(libfdproto PROPERTIES 
+	OUTPUT_NAME "fdproto"
+	SOVERSION ${FD_PROJECT_VERSION_API}
+	VERSION ${FD_PROJECT_VERSION_MAJOR}.${FD_PROJECT_VERSION_MINOR}.${FD_PROJECT_VERSION_REV})
+
+# The library itself needs other libraries 
+TARGET_LINK_LIBRARIES(libfdproto ${LFDPROTO_LIBS})
+
+
+####
+## INSTALL section ##
+
+INSTALL(TARGETS libfdproto
+	LIBRARY DESTINATION ${INSTALL_LIBRARY_SUFFIX}
+	COMPONENT freeDiameter-common)
+
"Welcome to our mercurial repository"