diff libfdproto/CMakeLists.txt @ 1562:6219359a36a9 default tip

Merge latest changes from proposed branch
author Sebastien Decugis <sdecugis@freediameter.net>
date Mon, 21 Jun 2021 19:08:18 +0800
parents 699c3fb0c57b
children
line wrap: on
line diff
--- a/libfdproto/CMakeLists.txt	Sat Oct 10 12:58:37 2020 +0800
+++ b/libfdproto/CMakeLists.txt	Mon Jun 21 19:08:18 2021 +0800
@@ -2,10 +2,7 @@
 Project("libfdproto" C)
 
 # Configuration for newer cmake
-cmake_policy(VERSION 2.6)
-if (POLICY CMP0022)
-	cmake_policy(SET CMP0022 OLD)
-endif (POLICY CMP0022)
+cmake_policy(VERSION 2.8.12)
 
 # List of source files for the library
 SET(LFDPROTO_SRC
@@ -30,12 +27,12 @@
 # Save the list of files for testcases in the core's directory
 SET(LFDPROTO_SRC ${LFDPROTO_SRC} PARENT_SCOPE)
 
-# Include path
-INCLUDE_DIRECTORIES(${LFDPROTO_INCLUDES})
-
 # Build as a shared library
 ADD_LIBRARY(libfdproto SHARED ${LFDPROTO_SRC})
 
+# Include path
+TARGET_INCLUDE_DIRECTORIES(libfdproto PRIVATE /a/b/c ${LFDPROTO_INCLUDES})
+
 ADD_DEPENDENCIES(libfdproto version_information)
 
 # Avoid the liblib name, and set the version
"Welcome to our mercurial repository"