view contrib/debian/rules @ 328:90294e7e986c

Moved the debian dir outside the top level directory
author Sebastien Decugis <sdecugis@nict.go.jp>
date Fri, 28 May 2010 17:19:22 +0900
parents debian/rules@48225b1db9d4
children 2bf23d10bc6f
line wrap: on
line source

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
#
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
#
# Modified to make a template file for a multi-binary package with separated
# build-arch and build-indep targets  by Bill Allombert 2001

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

# This has to be exported to make some magic below work.
export DH_OPTIONS

# Uncomment this to run the tests when the package is built
# compile_the_tests=-DSKIP_TESTS:BOOL=OFF

%:
	dh  $@

override_dh_auto_configure:
	dh_auto_configure -- $(compile_the_tests) \
		-DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
		-DDEFAULT_CONF_PATH:PATH=/etc/freeDiameter \
		-DBUILD_APP_ACCT:BOOL=ON \
		-DBUILD_APP_RADGW:BOOL=ON \
		-DBUILD_DBG_MONITOR:BOOL=ON \
		-DBUILD_DBG_RT:BOOL=ON \
		-DBUILD_TEST_APP:BOOL=ON \
		-DBUILD_APP_ACCT:BOOL=ON
		

"Welcome to our mercurial repository"