view contrib/debian/rules @ 560:d300c5213e45

Fix broken packaging
author Sebastien Decugis <sdecugis@nict.go.jp>
date Wed, 15 Sep 2010 18:58:39 +0900
parents bfe99640cdfa
children 7ae66129fd73
line wrap: on
line source

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
#
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
#
# Modified to make a template file for a multi-binary package with separated
# build-arch and build-indep targets  by Bill Allombert 2001

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

# This has to be exported to make some magic below work.
export DH_OPTIONS

# Comment this out if you want to include the tests when the package is built
skip_the_tests=-DBUILD_TESTING:BOOL=OFF

%:
	dh  $@

override_dh_auto_configure:
	dh_auto_configure -- $(skip_the_tests) \
		-DCMAKE_BUILD_TYPE:STRING=DebianPackage \
		-DDEFAULT_CONF_PATH:PATH=/etc/freeDiameter \
		-DBUILD_APP_ACCT:BOOL=ON \
		-DBUILD_APP_DIAMEAP:BOOL=ON \
		-DBUILD_EAP_MD5:BOOL=ON \
		-DBUILD_EAP_TLS:BOOL=ON \
		-DBUILD_APP_RADGW:BOOL=ON \
		-DBUILD_RGWX_SIP:BOOL=ON \
		-DBUILD_APP_SIP:BOOL=ON \
		-DBUILD_DBG_MONITOR:BOOL=ON \
		-DBUILD_DBG_RT:BOOL=ON \
		-DBUILD_RT_EREG:BOOL=ON \
		-DBUILD_TEST_APP:BOOL=ON \
		-DBUILD_TEST_SIP:BOOL=ON
		

"Welcome to our mercurial repository"