view contrib/debian/rules @ 1522:fa7874f2bfee

Rename Additional-Context-ID (1683) Note: 3GPP TS 29.272 table 7.3.1/1 row Additional-Context-ID (1683) has incorrect name and should be "Additional-Context-Identifier" per clause 7.3.206. Fix: Additional-Context-ID (1683) renamed to Additional-Context-Identifier (1683).
author Luke Mewburn <luke@mewburn.net>
date Fri, 17 Apr 2020 14:21:55 +1000
parents 7ae66129fd73
children
line wrap: on
line source

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
#
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
#
# Modified to make a template file for a multi-binary package with separated
# build-arch and build-indep targets  by Bill Allombert 2001

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

# This has to be exported to make some magic below work.
export DH_OPTIONS

# Comment this out if you want to include the tests when the package is built
skip_the_tests=-DBUILD_TESTING:BOOL=OFF

%:
	dh  $@

override_dh_auto_configure:
	dh_auto_configure -- $(skip_the_tests) \
		-DCMAKE_BUILD_TYPE:STRING=DebianPackage \
		-DDEFAULT_CONF_PATH:PATH=/etc/freeDiameter \
		-DALL_EXTENSIONS:BOOL=ON
		

"Welcome to our mercurial repository"